Unable to create EvictionPolicy instance of type org.apache.tomcat.dbcp.pool2.impl.DefaultEvictionPolicy

Description

None

Environment

Confluence:5.8.5
OS:Linux crem 3.13.0-39-generic #66-Ubuntu SMP Tue Oct 28 13:30:27 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
PlaySQL version 5.10.4

Observations

After confluence upgrade to version 5.8.5 playsql stops to work. Instead on result I see message:

confluence log contains exception like this.

Activity

Show:
Adrien Ragot (Old account)
July 13, 2015, 7:55 AM

Thank you very much for your bug report. It will be helpful to other customers too and I'm thanksful that you've triggered an alert. I'll publish this version.

TomaszB
July 13, 2015, 7:12 AM

It's working. Thank you.

Adrien Ragot (Old account)
July 10, 2015, 2:50 PM

Hi Thomas,

I've attached playsql-plugin-2.10.6.obr to this issue. This is a version of the plugin with a fix for the classloader, which was the problem you had with JNDI. It works well in my environment, can you check whether it solves the issue in your situation?

Thank you very much,
Adrien Ragot

Adrien Ragot (Old account)
July 10, 2015, 11:20 AM

Yes it is definitely possible. This will certainly be blocking for other customers as well. I hope to issue a bugfix before Monday.

TomaszB
July 10, 2015, 10:36 AM

It would be great for me to have fix before end of this month. Is it possible ?

Resolved

Assignee

Adrien Ragot (Play SQL / Requirement Yogi)

Reporter

TomaszB