Bug with Confluence 5.9.1 compatibility

Description

Symptom

There is a problem with the compatibility for Confluence 5.9.1.

  • SAL was upgraded to 3.0.5,

  • The Postgres driver only works in the JDBC 4.1 version, and it can't use JDBC 4.2.

I didn't notice it while testing, because it was installed through the SDK. It needs to be fixed.

Diagnostics screen

Since it is not easy to debug the bug above, we're introducing a diagnostics screen. To reach it:

  • You must be an administrator

  • Set the system property -Dplaysql.diagnostics. This system property doesn't impact the performance and can remain active.

  • Go to the Play SQL administration and click "Diagnostics".

Be aware that it actually changes data if you make edit rows/execute SQL.

Environment

None

Observations

None

Assignee

Adrien Ragot (Play SQL / Requirement Yogi)

Reporter

Adrien Ragot (Old account)

Labels

None

Participants

None

Fix versions

Priority

Configure