Could not display PlaySQL: error

Description

Good Morning,

We have updated our confluence server to version 6.10 and the playSQL add-on to latest version 3.0.2

Now, all pages that had SQL queries are not showing the data and showing the error "Could not display PlaySQL: error" (

)

On the atlassian logs side, its shown:

2018-09-03 17:50:02,330 ERROR [http-nio-8090-exec-3] [common.error.jersey.ThrowableExceptionMapper] toResponse Uncaught exception thrown by REST service: Can not instantiate value of type [collection type; class java.util.ArrayList, contains [simple type, class com.playsql.core.model.UserParameter]] from JSON String; no single-String constructor/factory method (through reference chain: com.playsql.base.rest.QueryRequest["user-parameters"])
โ€“ referer: http://confluencedev.wedo.pt/display/TECHSUPP/Latest+Stable+Builds | url: /rest/playsql/1.0/playsql/html | traceId: 3189f571cef3c38e | userName: admin
org.codehaus.jackson.map.JsonMappingException: Can not instantiate value of type [collection type; class java.util.ArrayList, contains [simple type, class com.playsql.core.model.UserParameter]] from JSON String; no single-String constructor/factory method (through reference chain: com.playsql.base.rest.QueryRequest["user-parameters"])

Here is the storage code of the page:

<h2>Stable Builds</h2>
<p><br /></p><ac:structured-macro ac:name="playsql" ac:schema-version="1" ac:macro-id="7344b994-1361-47cb-bfac-01695ad5e15f"><acarameter ac:name="context">space:</acarameter><aclain-text-body><![CDATA[SELECT
/*+ PARALLEL(4) */
REGEXP_REPLACE(BL_ID,'(._R\d+.\d+).','\1') PROJECT, BL_ID, STATUS, START_DATE, END_DATE
FROM BUILDADM.BLD_CREATED
WHERE TYPE = 'WD_REL_BL_LC'
ORDER BY START_DATE DESC]]></aclain-text-body></ac:structured-macro>
<p><br /></p>
<p>Simple select 1 from dual:</p><ac:structured-macro ac:name="playsql" ac:schema-version="1" ac:macro-id="0cd2be68-d195-4476-92cc-bce018a1fdaf"><acarameter ac:name="context">space:</acarameter><aclain-text-body><![CDATA[SELECT 1 from dual
]]></aclain-text-body></ac:structured-macro>
<p><br /><br /></p>

Can you check why the pages stops displaying correctly the data ?

best regards,
Cristรณvรฃo

Environment

None

Observations

None

Assignee

Adrien Ragot (Play SQL / Requirement Yogi)

Reporter

TechS

Labels

None

Participants

None

Affects versions

Priority

Matter of hours
Configure