Warn the users when they run Java 6

Description

  • Play SQL is compatible with Java 6 but requires the users to bring their own Java-6-compatible driver (see specifications)

  • The version of Postgres shipped in Play SQL requires Java 7, and there's hardly anything we could do to detect a class-level exception beforehand,

  • We should at least warn users during setup, so they don't meet this issue.

Environment

Java 6

Observations

Some users report "a crash" when opening Play SQL's index page. The log says:

This means they use Java 6.

Assignee

Adrien Ragot (Play SQL / Requirement Yogi)

Reporter

Adrien Ragot (Old account)

Labels

None

Participants

None

Components

Fix versions

Priority

Configure