Javascript Error Causes Broken Layout

Description

when enabling requirements yogi in confluenc 6.2.1 and using the macros, a javascript error occurs that breaks the confluence sidebar (see screenshot)

Environment

Confluence 6.2.1
Firefox 54

Observations

None

Activity

Show:
Adrien Ragot (Old account)
July 31, 2017, 3:51 PM

Hi Philine,

It should work now! Sorry again for the delay and the misunderstanding, hope the new release will fix your problem!

Best regards,
Adrien

Philine Mitrea
July 28, 2017, 12:59 PM

Hello,

I'm glad we could find an understanding again. Yes, just set those comments to private, and we will forget about it.

Kind regards,
Philine

Adrien Ragot (Old account)
July 28, 2017, 12:56 PM

Hi Philine,

I have just noticed that I've missed the email where you list the add-ons. I must have marked it as 'read' by mistake and I was (wrongly) upset that you didn't provide the list of add-ons.

I have to apologize for being wrongly upset, and mismanaging my email was my mistake too. I believe I have enough information now and I'm immediately starting to work on solving this issue. I hope to deliver an bugfix before Monday (and hopefully before).

Do you mind if we delete the last two messages or make this issue private? As you have done everything perfectly, the misunderstanding and the delay was only my mistake.

Thank you very much for quickly correcting my misunderstanding,
Adrien

Philine Mitrea
July 28, 2017, 10:15 AM

Hi,

as we have already reported to Adrien, we confirm that Requirement Yogi for himself causes the broken layout with the JavaScript error. Upon disabling the add-on, the affected Confluence site has its correct output again. The issue persits with RY version 1.7.2, and we were able to reproduce it repeatedly. With no other add-ons active, the error happens when a RY macro sits inside a cell of the lower table. When the macro is moved outside of the table, e.g. at the top of the site the Confluence navigation appears again. Therefore we exported the storage format of both versions of the site - once with the present failure ("RY_issue_fail.html") and then with the unimpaired page ("RY_issue_works.html"). Please see the attached files below.

Best regards,
Philine

Adrien Ragot (Old account)
July 3, 2017, 12:28 PM

Hi Thomas,

I have tried, both in Windows and Mac, in Chrome, FF and Edge, and in Confluence 6.2.0 and 6.2.1, and I can't reproduce the issue.

  • Can you confirm that the error only happens when you deactivate Requirement Yogi?

  • Can you afford reactivating RY and deactivating other add-on, to see whether it could be the interaction between RY and another add-on which creates the issue?

  • If you are a programmer, would you be able to click on the Javascript red messages and try to find what add-on code causes the issue?

I'm really sorry for your problem, but if I can't reproduce it locally, I won't be able to solve it.
Best regards,
Adrien

Assignee

Adrien Ragot (Play SQL / Requirement Yogi)

Reporter

Thomas Rieder

Labels

None

Participants

None

Components

Fix versions

Affects versions

Priority