Requirement Link does not work

Description

When I link to a requirement on a certain page, it all works, the requirement is found, details are fetched:

But when I then save the page, it shows this error:

When I re-index the page, I get:

Environment

None

Observations

None

Activity

Show:
Albert Bloemendal
September 12, 2019, 11:11 AM

Hi Adrien,

Thanks for informing me.
I just installed the new version and it is working now.
Thanks for your quick support.

Regards,
Albert Bloemendal
+31 6 22 41 28 82

From: Adrien Ragot (Play SQL / Requirement Yogi) (Play SQL issue tracker) jira@playsql.atlassian.net
Sent: donderdag 12 september 2019 13:06
To: Bloemendal, Albert <albert.bloemendal@saabgroup.com>
Subject: [JIRA] () Requirement Link does not work

https://avatar-management--avatars.us-west-2.prod.public.atl-paas.net/557058:bf3d83df-a6de-4489-b326-eb2c2edb3f12/ceefc5e8-c340-412e-b891-a17f753a15e3/128?size=48&s=48

Adrien Ragot (Play SQL / Requirement Yogi) <https://playsql.atlassian.net/secure/ViewProfile.jspa?accountId=557058%3Abf3d83df-a6de-4489-b326-eb2c2edb3f12> commented on [Bug] RY-450<https://playsql.atlassian.net/browse/RY-450?atlOrigin=eyJpIjoiYzgzNjhlMjMxNTE3NDY4NmE0OTFmZDQyODZkMDdlZDYiLCJwIjoiaiJ9>

Re: Requirement Link does not work<https://playsql.atlassian.net/browse/RY-450?atlOrigin=eyJpIjoiYzgzNjhlMjMxNTE3NDY4NmE0OTFmZDQyODZkMDdlZDYiLCJwIjoiaiJ9>

Hi all,

Just to be clear, this issue was resolved in the release published yesterday, 2.2.3.

I’m sorry for not communicating much but half the company is at the developer sessions at Atlassian Open in Vienna.

Best regards,

Adrien

[Add Comment]<https://playsql.atlassian.net/browse/RY-450#add-comment?atlOrigin=eyJpIjoiYzgzNjhlMjMxNTE3NDY4NmE0OTFmZDQyODZkMDdlZDYiLCJwIjoiaiJ9>

Add Comment<https://playsql.atlassian.net/browse/RY-450#add-comment?atlOrigin=eyJpIjoiYzgzNjhlMjMxNTE3NDY4NmE0OTFmZDQyODZkMDdlZDYiLCJwIjoiaiJ9>

Get Jira notifications on your phone! Download the Jira Cloud app for Android<https://play.google.com/store/apps/details?id=com.atlassian.android.jira.core&referrer=utm_source%3DNotificationLink%26utm_medium%3DEmail> or iOS<https://itunes.apple.com/app/apple-store/id1006972087?pt=696495&ct=EmailNotificationLink&mt=8>

Adrien Ragot (Play SQL / Requirement Yogi)
September 12, 2019, 11:05 AM

Hi all,

Just to be clear, this issue was resolved in the release published yesterday, 2.2.3.

I’m sorry for not communicating much but half the company is at the developer sessions at Atlassian Open in Vienna.

Best regards,

Adrien

Michael Glatter-Götz
September 10, 2019, 6:56 AM

Adrien, yes, I’m in a cross-space scenario as well.

Adrien Ragot (Play SQL / Requirement Yogi)
September 9, 2019, 4:08 PM
Edited

Hi,

Michael and Albert, we've succeeded to reproduce thanks to Albert's tips. We'll try to make a release very soon.

Michael , are you also in the situation of cross-space requirements? If not, are you working on an actual page? Do you have something special with that page, such as an 'include' macro or similar?

Best regards,
Adrien

Albert Bloemendal
September 9, 2019, 2:33 PM
Edited

We are using the latest version 2.2.2 and observe the same error when we link requirements between different spaces.
The requirement link is shown in red and when we hover over it the error message is shown in a popup window instead of showing information about the requirement.
Furthermore when we list the requirements by clicking ‘requirements’, all requirements within the space are shown, except the linked requirements.
We think that the problem has been caused due to one of the latest updates, because we think that it was working correctly in the past. But we are not sure:-(

Resolved

Assignee

Adrien Ragot (Play SQL / Requirement Yogi)

Reporter

Michael Glatter-Götz

Labels

None

Participants

None

Components

Fix versions

Priority

Matter of days