RY Report: Non latin named property being used in report field "Columns" results empty values

Description

Reproduce scenario

Step1
Create a page containing following data:

RQID

RQ Definition

Авторы

RQ-001

System should do thing

Имя Автора

Step2
Create a page containing RY report with search query:
key ~ 'RQ-%'
and Columns field as following:
@Авторы

Expected result
On a page containing RY Report macro:
RY Report table has column named Авторы
RY Report table has 1 record containing value "Имя Автора" in column "Авторы"

Actual result
On a page containing RY Report macro:
RY Report table has column named Авторы
RY Report table has 1 record containing empty value

Environment

None

Observations

None

Activity

Show:
Adrien Ragot (Play SQL / Requirement Yogi)
January 24, 2020, 1:54 PM

Hi Alexander,

This should be fixed for you now, as part of v2.4.5. Tell me how it goes!

Best regards,
Adrien

Adrien Ragot (Play SQL / Requirement Yogi)
January 20, 2020, 4:05 PM

This will be included in the next release (most probably Friday).

Alexander Luchkov
January 19, 2020, 9:03 PM

That’s fine

Adrien Ragot (Play SQL / Requirement Yogi)
January 19, 2020, 8:48 PM
Edited

Oh, sorry I hadn’t seen your first comment. I’ll do it.

Alexander Luchkov
January 19, 2020, 8:45 PM

Could you please set me as author. Strange, but my browser used wrong ID to log me in. Thanks in advance.

Resolved

Assignee

Adrien Ragot (Play SQL / Requirement Yogi)

Reporter

Alexander Luchkov

Labels

None

Participants

None

Components

Fix versions

Affects versions

Priority

Matter of months